Info
Our site was created on August 30, 2021. He is quite young, so we ask you not to leave so quickly! Bookmark us!, please
The site is testing an automated system for adding mods, so pages may not be available
Latest comments
Razilator
@Razilator RimJobWorld [+18]

Mod updated to the current version.

1 week, 4 days ago
Razilator
@Razilator Combat Extended

PyWorker, I will improve you!

4 weeks, 1 day ago
PyWorker
@PyWorker Combat Extended

My great job at automating uploads! My version: 0.3. I try to improve according to my mood.

4 weeks, 1 day ago
Razilator
@Razilator Mechalit Core (Continued)

I speak as an admin, I only played with the Mechalit Core mod. Now another person has continued his work, adapting it to Rimworld 1.3.

2 months, 2 weeks ago
Razilator
@Razilator Victoria 8 Pro Bundle (G8F)

Nice, I like

2 months, 3 weeks ago
Demalius
@Demalius Dark UI

Demalius, тест 4

2 months, 3 weeks ago

Harmony
0

  • #Core and Framework
  • Added: 2 months, 2 weeks ago
  • Updated: 2 weeks, 1 day ago
  • Views: 36
    Author(s): Brrainz
  • Version: 1.0, 1.1, 1.2, 1.3
    Loads: 13
Link Info Language Version Loads Loaded Created by
Go to download 894 KB Multi 1.0, 1.1, 1.2, 1.3 13 10/08/2021 в 21:52 Razilator
Content

This mod contains the C# library Harmony for all RimWorld mods.

Harmony is a library that is used by many mods. In RimWorld 1.x or older the library was included inside C# mods and there was no need to load it as a separate mod. However, RimWorld versions after 1.x changed that and including it in every mod is no longer possible so it needs to be loaded before any other mod. Place this mod all the way on top of the mod list and before Core.

FAQ

Q: I get lines like "Fallback handler could not load library" in my log!
A: These are not errors and can simply be ignored. There is nothing wrong (any mod that uses code will trigger those bogus messages)

Q: Why do I need this mod?
A: You don't need it but one of your mods depends on it to work correctly.

Q: What does it do?
A: Nothing. To be exact: stuff that mod programmers want and need. It cannot cause any errors by itself.

Q: Should this really go above the Core?
A: Yes, it must be first in the list.

Q: Does this work with RimWorld 1.x
A: No, there is no need for a Harmony mod in that version.

Comments